不能安装LXML(蟒蛇2.6.3,OSX 10.6雪豹)

<p>我尝试: P&gt; </p>

<p> easy_install的LXML P&gt; BLOCKQUOTE&gt; </p><p>和我得到这个错误: P&gt; </p>> <p>文件“建立/ bdist.macosx-10.3-脂肪/蛋/ setuptools的/命令/ build_ext.py”,行85,在get_ext_filename KeyError异常:“etree” P&gt; BLOCKQUOTE&gt; </p><p>任何提示? P&gt;

</p></blockquote></blockquote>

64 浏览 1 回复
  gt   setuptools   blockquote   错误   分发  

回复

    <p>由于不兼容的改变2.6.3版本的Python的的distutils,老 从 setuptools的不再起作用。您需要将其替换 从分发。按照指示,基本上是: P&gt;</p><p>假设2.6.3 是您第一个 P&gt; </p><p>编辑:除了选择从setuptools的到分发,Python的2.6.4,它应该被释放在几个星期的迁移,将包含的<a href="htt p://svn.python.org/view?鉴于=转和放大器;审校= 75256" rel="nofollow"> 的解决方法中的distutils将别让setuptools的一&gt;。谢谢你,塔里克,为修复和感谢,jbastos,将这一问题了。 P&gt; <p>进一步编辑: setuptools的本身已经更新(截至),以解决该问题2.6.3。 P&gt; </p><p>斯内德: P&gt; </p>

    <p>不兼容的更改在2.6.3版本的Python的distutil的 P&gt; BLOCKQUOTE&gt; </p><p>不准确。该API不变但setuptools的覆盖它们,并使得它们被称为在一个特定的顺序的假设。 P&gt; </p><p>伦纳特: P&gt; </p>> <p>分发安装似乎并没有触发错误 P&gt; BLOCKQUOTE&gt; </p><p>确实是这样,这种精确的错误检测前一段时间和固定的分配(在Ubuntu的setuptools的包) P&gt;

    </p></blockquote></blockquote></p>

    熊偲

相关信息

不能安装LXML(蟒蛇2.6.3,OSX 10.6雪豹)

<p>我尝试: P&gt; </p> > <p> easy\_install的LXML P&gt; BLOCKQUOTE&gt; </p><p>和我得到这个错误: P&gt; </p>> <p>文件“建立/ bdist.macosx-10.3-脂肪/蛋/ setuptools...

1 浏览 1 回复   gt   setuptools   blockquote   错误   分发  

可以分发setuptools的可用于在Python 2实施3口包

<p>发现使用分布在以下链接setuptools的蟒蛇从2移植包3的一些信息。 P&gt; </p><p> [ http://packages.python.org/distribute/python3.html ](http://packages.python.org/distribute/python3.html) &lt; / p&gt...

3 浏览 1 回复   python   gt   使用   代码   api  

确定的easy_install / setuptools的版本

<p>我试图安装couchapp,它使用easy\_install的 - 而且是在陈述easy\_install的特定版本比较明确/需要的setuptools:0.6c6。我似乎已经easy\_install的已经在我的Mac,但没有命令行参数来检查版本。而不是仅仅安装新版本在上面的,我想看看它是否是必要的。 P&gt; </p><p>所以:在我能怎么看setuptools...

20 浏览 1 回复   gt   install   easy   版本   setuptools  

PyObjC +的Python 3.0的问题

<p>默认情况下,可可Python应用程序将使用默认的Python运行时是2.5版。我该如何配置我的Xcode项目,以便它使用新的Python 3.0运行时?我试图取代包括在与较新版本的项目的Python.framework,但没有奏效。 P&gt; </p><p>和另外一件事,是PyObjc模块与Python的新版本兼容? P&gt; </p>

13 浏览 1 回复   python   gt   pyobjc   版本   支持  

摊铺机与Python 2.6 0.8.1的兼容性

<p>有谁设法引导使用摊铺机的开发面积与Python 2.6? P&gt; </p><p>我有安装python 2.6,与使用easy\_install - 2.6安装摊铺机,一切都看起来很好。 但是,当我尝试启动它引发urllib2.HTTPError引导方法(:HTTP错误404:未找到)尝试下载的<a href="htt​​p://pypi...

9 浏览 1 回复   gt   尝试   python   摊铺机   摊铺